Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: A Clockwork Syringe blog
PostPosted: April 27th, 2011, 7:50 pm 
Steel Member
User avatar

Joined: February 1st, 2011, 6:13 pm
Posts: 30 us
RS Name: Jmycenae
RS Status: P2P
A Clockwork Syringe

Very belated quest journal.

It’s been almost a month since this thing came out. I feel like I am really lagging in getting around to it. But better late than never, eh?

Where to start A Clockwork Syringe:

Go to your player-owned house portal and talk to Postie Pete, then read the delivery note attached to the portal.

Requirements to start A Clockwork Syringe:

50 Dungeoneering
61 Slayer
62 Construction
65 Summoning
74 Smithing
74 Thieving
76 Defence
Rocking Out

At the Poh portal there is a Clockwork Syringe option. Pick that, there is a delivery note stuck to the portal. Take it and it goes in my backpack. When I read it, the quest start box pops up. Say yes to start the quest.

The note says “RPDT Delivery Note. A parcel consisting of: 1x large and totally inconspicuous crate assured to not contain anything dangerous at all has been delivered to your player-owned house. Note: content of package unchecked by RPDT and sender’s assurances are not backed by RPDT.”

Why do I feel like I should be alerting the Department of Homeland Security? I suspect that is not a quest option though. I imagine I will be blundering straight into this as usual.

Ah dear. Now when I do the C.S. option on the portal, I get a warning that Some players may find the following scenes distressing. There are no kitten cutscenes to protect your innocence this time. I investigate the mystery package anyway.

When I enter my house a large crate is standing by the portal. When I check it out, Barrelchest MK II pops out, level 188. Examine info: It’s trying to mash your house! Less examine, more fight!

So I attack it, and during the battle it is seriously smoshing around and destroying stuff in my house. There go portals, doors, etc. During the fight it says prepare yourself and then jumps up and something new is destroyed and I am pushed back, knocking the breath out of me and damaging my health. I don’t know if this is a glitch, but my health bar appears fully green, but my health points are down quite low - careful during this fight to pay attention to the numbers, not just the green/red bar.

When I kill Barrellchest MK II, cut scene seems to end and my house is back. Standing there now is the Estate Agent (whose head is weirdly stuck inside my yew tree there) and a Zombie Head in a barrel, which I believe was the head of the thing I just killed.

The estate agent says he is checking to make sure the repairs are satisfactory. He brushes aside my concern about cost, saying that my standard player-owned house contents insurance policy was recently updated to include acts of zombio-mechanical piracy.

Hmm. Brief break while I call my State Farm agent to ensure that I have that important coverage.

Ok, back.

Hmm. My State Farm agent doesn’t seem to know about that type of coverage. Maybe time to switch to Allstate?

Anyway, back to the quest. The estate agent clarifies that the policy doesn’t include removal of the perpetrator of the attack - I have to deal with that part myself. He takes the delivery note to keep in the claim file and teleports out.

Over to interrogate the Zombie Head. OMG! Jagex has lost it. The Zombie won’t answer my questions, so up pops this Zombie Stress Level chart showing 5 methods I can use to essentially torture the head until he will talk. I insult him and poke him and squeeze him until his stress level is maxed and he agrees to talk. Agh!

He says I have made some powerful enemies. He was sent by Captain of This Albatross, condemned to the depths by those friends of mine. He is back to wreak vengeance. Glad my character remembers the questlines, because that wasn’t ringing a bell with me. But my little chathead exclaims “Rabid Jack!” Apparently the plan is to unleash an army of barrelchests on Mos Le’Harmless.

I need to go warn Bill Teach. I stuff the Zombie Head in my pack over its protests. Ew.

Hm, my health points just won’t go up again, and even eating food isn’t helping. Stuck at 560 out of 990. I tried logging out and on just in case it was a glitch, but it stayed. Even the enchanted Excalibur and super restore potions aren’t helping. Do I just have to wait for it to gradually increase over time? Guess so, it is very slowly rising.

Take my Ectophial to Port Phantasmys to go to Bill Teach’s ship. He tells me to meet him in Joe’s House of Rum in northern Mos Le Harmess. I am to ask for a drop of Long Drop, and affirm Aye, drop me when Joe asks if I am sure. Um, ok. I still have the travel option, so at least he takes me there.

I go into the bar and sit in the chair in the corner. When I place the order as instructed, the seat drops me through a trap door, and underneath in the basement Bill Teach is waiting. Whoa, subterfuge!

I complain that every time a pirate tells me to go somewhere, I end up with a headache.

When I tell him I have news of Rabid Jack, he tells me to stop saying that name. I respond with “Dammit Bill! We don’t have time for this!” Gadzooks Jagex, really? First torture and now cursing? This quest is a bit scandalous!

I tell him the story, and he wants to see evidence. He tells me to put it on the table. Ok, he asked for it. I put the zombie head on the table. He is speechless for a moment, then contemplates the fact that he only wishes this is the weirdest thing we’ve done together.

The head insists that no torture will make it reveal the location of the Barrelchest factory. Bill asks me to go to Braindeath and get some special equipment: Twiblik Night Special. He gives me a paper with teleports between Braindeath Island and Mos Le Harmless. I have to be upstairs and with space north of me to cast the spell, it seems. When I cast it, Pirate Pete appears and cracks me on the head, and I wake up with him on Braindeath Island.

I go into the building to talk to Captain Braindeath. I tell him I need the Twiblik Night Special, but he has problems of his own: some of his brewers have gone missing. They were investigating an odd doorway to the north which was uncovered in a minor earthquake. These 3 were fresh recruits from Daemonheim and said they could figure it out. They haven’t come back in 3 days. If I rescue these brewers he will give me what I need for Bill Teach. I need to at least bring him proof of their fate since his hopes of an actual rescue aren’t high.

He says I need to take something to help me breath underwater since it appears to be flooded on the other side. When I say I have left my diving gear in the bank, he offers to let me have his, and he will take mine from my bank later. Well that is convenient!

I head past 50% Luke to the north part of the island. My health is still slowly, slowly rising, up to 773 now. Have no idea if this is supposed to be part of the quest or a glitch - might look online later for that answer.

There is a Mysterious Entrance just north of Luke, looking like the Dungeoneering special dungeon entrances. I put on my diving helmet and apparatus. In I go. And am immediately attacked by lots of weird rum crabs, and something called General Malpractitioner, and there are tons of them, I can’t seem to effectively fight them. I run around inside fending them off, and find 2 bodies, but I can’t even search the bodies long enough to see what the chat screen says before being attacked again. I think I am supposed to take something from the bodies, but am being attacked by too many opponents at one time. Also get poisoned. Teleporting out to get more food and think of a better strategy. At least I can get my health points all the way up now.

I have cheated and checked out a quest guide, which points out that the creatures attack with melee and ranged. So I am going to wear better melee armor and protect against ranged next go-round. The plan is to go down each of three paths to where the bodies are, close the door behind me, kill the General Malpractitioners and crabs just like clearing a dungeon, then search the bodies. Sounds simpler than it felt when I was getting attacked all around. Ok, heading back to Braindeath Island.

Things go much smoother with an actual plan. Just clear each room like in dungeoneering, then can search the bodies to get their names. These creatures have decent drops, by the way. The name badges are Trent, Jimmy and Rory. I head back to Captain Braindeath to tell him the news. I tell him that I found the dead brewers, and zombie surgeons injecting rum into the wildlife, making the crabs very big and aggressive.

He is ready with the Twiblik special, but I have to swear a mighty oath first. “The Oath” is predictably silly. He gives me a locked chest with the Twiblick night special and says Bill Teach has the key.

I use the teleport back to Mos Le Harmless, involving another crashing headache. Get dropped down in the pub again, and Bill and the zombie head are still down in the basement. He unlocks it after ensuring I have taken The Oath. He says when I have mentally prepared myself I should open it. Er... ok.

When I try to open it I get another warning that if I open it, it could scar me forever! I will take the risk. When I finally get it opened, I find it full of feminine wigs and various kinds of make-up. Huh? When I ask Bill Teach why they have a secret box full of women’s apparel, he accuses me of forgetting The Oath: what happens at sea, stays at sea!

Oooooooooooo-kay. Bill Teach tells the zombie we are going to beautify him and parade him around in front of his old crew. The zombie is very alarmed. I get a lot of options about new hairstyles and colors for the zombie.

Yeah, this quest is just weird. Anyway, start selecting hair and styling options, don’t know if there is a specific right answer here. When we are done, the zombie finally agrees to talk, after being inflicted with beautiful hair and makeup. Er....

Anyway, the zombie instructs us to sail with a relative bearing of 223 degrees from Harmony for 500 cable lengths. Bill says that is 50 nautical miles. East will be a beacon, sail towards that for 120 fathoms, then go starboard. There is a rock formation, we need to go in and find a lagoon. Bill is alarmed that it is the lair of the many-tentacled beast of unpleasant encounters. From there, we sail straight out the other side, then starboard around the reef, close to land, and we will see an island in the distance. Bill says that would be Bloodspatter Isle, which is south of here, why didn’t the zombie just say so!? The zombie admits it was trying to get us to take the long way around and sink. Bill says he knows right were we are going and I should meet him at the ship.

Ah, brief detour, there is a crashed star right here. Can’t really pass that up.

OK back to the quest. Bill Teach tells me on the boat ride to Bloodspatter Isle that he is dubious of “You Know Who’s” involvement in this, and I will need to find proof. Keep thinking he is talking about Voldemort when he says that. I am a mage, after all....

He says that once I find proof of what the zombie head claimed, action will be taken to protect Mos Le Harmless.

As we approach the island, we are attacked by cannonfire from the island. He has a plan to get around the attackers. He wants me to use some gunpowder to attach a chain to a cannonball. I can find these supplies below. The other end of the chain needs to be attached to an empty barrel. Then I sit on the barrel and use the cannon to cannonball myself onto the island. Sounds painful, but I guess I’ll do it.

I go down into the hold and construct the barrel cannon boat thing. Using all the various items together and the anvil I make the boat, exclaim “Sweet.” and go upstairs. He wants me to load 2 doses of gunpowder, grab the barrel, fire the cannon and hold on for dear life. Once I get to the island I should knock out the guns which are firing on the ship. I go downstairs to get 2 more doses of gunpowder, then take the ride with the cannon on deck.

Best cut scene ever! I am clutching on to the barrel for dear life and go zooming out the cannon and onto the island.

Where I land there is a perch rock to investigate. A seagull comes down to talk to me and claims I inflicted devastation. When I claim not to remember, it says it kept my shirt and accordion. I remember it is the seagull from the Rock that I fired at Young Ralph’s head. (What? I don’t have a great memory for old quests, I fear.) The seagull says it is Baron von Hattenkrapper. Har Har Har. It had come to have revenge for me shooting it out of a vacuum pump, but then saw me shot out of a cannon. It wants to know if that was my way to atone. Er, sure. It accepts my apology and says it has a proposal. He wants to work together to defeat our common enemy, the monstrosities who opened fire on my ship. They also fire upon the seagull whenever he tries to leave the island. The bird can lift cannonballs and fly, but needs to concentrate to do so. I am a skillful summoner. I can commune with ol’ Kattenkrapper and control his actions, so he can drop the cannonballs on the enemy.

I agree. Next we see the seagull flying with a cannonball held in its feet, and there is an interface to control the direction of its flight, and a bombs away button. You have to fly the seagull near the barrelchests and drop the bomb a little in advance because there is a delay. The damage to the barrelchests is always 1337, hilarious leetspeak. There are 5 or 6 of these things to cannonball.

When we are done we talk again and agree to remain allies. He suggests I go back to my ship, so I swim back and talk to Bill Teach. I tell him about defeating the enemies and he wonders why it can’t ever be something normal when I tell him about the seagull. He can go to the island now so he takes me back to start my investigation.

I go inside the factory. New music track “The Factory Floor”. There are zombies around called things like Dis-orderly, Attendead, and Grimtern. They are attending the equipment to make more barrelchests. When I go out into the open General Malpractitioner finds me, knocks me out, and locks me up. I want to escape and get back to Bill Teach. I unlock the door and go back down to the dock and summon Bill. I tell him there is a storage area I can access but the rest of the place is patrolled by zombie surgeons armed with syringes. In the area I can access are medical supplies and a dismantled barrelchest. He suggests I disguise myself as a barrelchest, using a roll of bandage, surgical mask, bundle of parts and a barrel. When I have all that I should come to him and we will build a disguise.

I get all this stuff from the storage area near the dock and go back to the ship. He makes a disguise using the zombie head on top, sealing up his mouth with the bandage and mask so he can’t say anything and betray my presence.

I go back to the island and put on the disguise. The examine info for the disguise is “You’re supposed to look less conspicuous in this?” I go stomping around investigating in my disguise.

I talk to the Attendead in one room where there are incomplete barrelchests, and he asks me to help load them on. I want to sabotage this explosively. I remember that in the supply room there was gunpowder and barrels, so I go and get some barrels and fill them with gunpowder (have to take off disguise - it is too big to fit in there). I put the three barrels with gunpowder on the tables and can detonate them. I have a feeling I should look around first before I do that, so I am going to wait until I investigate further.

When I turn around to investigate a notice board, my chat head says I need to do something about the surgeons first so they don’t get suspicious.

In another room there are massive arms on tables, and I sabotage their straps. Cut scene where the Residead surgeons are apparently being slaughtered by the massive arms - only thing you see is my disguised self cowering in fear from the horrific display. When it is over, i think that it is safe to investigate now.

However, when I go back to the noticeboard in the other room, I still want to do something about the surgeons. Think I will go ahead and detonate these barrels to get rid of the Attendead in this room. Yep, they blow up and it dies.

On the notice board I find a suspicious letter and put it into an evidence file. I apparently need to find 5 letters to fill all the spots in the file.

When I go out in the middle a Grimtern starts attacking, and I have the choice to Anchor or Cannon it. Cannon seems to stun them, and anchor kills them. Go around killing several of those things. Get a letter from a notice board in their room.

In another room are Disorderlys and a notice board, I need to distract them so I can investigate it. However, simply using the distract option doesn’t seem to work. Ah, there are gas canisters, and one has a sabotage option. Do that, it is laughing gas. I can now tell joke to each to distract them and investigate the notice board in here. Once they are bent over in helpless laughter, I can brutalize them, which kills them, then go to the notice board. I get another letter.

Another room has occupied surgery beds, but the zombies in there are totally drunk. No problem looking at the notice board in there.

Go back and investigate a notice board in the massive arm room that I hadn’t seen earlier.

I now have 5 letters in the evidence file and need to take it back to Bill Teach. The letters are instructions to the workers in each room from “Mi-Gor”. The final letter is from Rabid Jack to Mi-Gor.

Bill believes me now and gives me a stack of kegs to destroy their production line. I won’t need the disguise anymore since I have killed all the guards. Bummer, I want to keep that disguise and stroll all over Runescape in it!

In the back I find some conveyer belts with a nearby lever. I realize that if I turn on the machine I can use the conveyer belts to take explosive kegs into the machinery.

Strange cut scene that you can interact with, zombies start coming out from behind the other side of the wall. you can load the kegs onto each of the 3 conveyers belts, killing the zombies attacking on them, until all the belts are destroyed and the machinery grinds to a halt. Mi-Gor and Mechanical Murphy are there, and they flee toward the docks at the back of the facility.

I try running outside but can’t get around, so I go back inside. Where I had blown up the machine it knocked the wall down, I can jump over it and go outside to the docks.

Go down a ladder at the end and I see them there with zomboats that they escape on. They leave one zomboat behind, and I climb into it. Out in the sea are 5 enemy zomboats to battle, with Mi-Gor, Murphy and 3 zombies. You have to navigate around and fire at them, repairing your own boat as necessary. I discover you don’t really have to steer - you can just click on the boats to fire at them. Mi-Gor and Murphy vow to return as I sink them. One of the zombies just wails “the huge manatee!” as it goes down. Ouch.

I sail the zomboat back to Bill’s ship. He saw the battle and congratulates me, and we head back to Mos Le Harmless to meet in the bar again. Time for the long drop and another headache.

He is going to prepare for war. He will keep my disguise in case I need it again in the future. He will contact me when I am needed again.

Quest complete:

1 quest point
19k defense xp
18k smithing xp
18k thieving xp
15k summoning xp
11,250 construction xp
11,000 slayer xp
5k dungeoneering xp
Braindeath Island Rumgeon
Pirate spell sheet

Total quest points: 316

 Post subject: Register and login to get these in-post ads to disappear
PostPosted: April 27th, 2011, 7:50 pm 
Steel Member

Joined: September 9th, 2004, 1:47am
Posts: 9047
Location: In your web browserz

Display posts from previous:  Sort by  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to: